#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "At_[-0-9.]*_displacement"
Local $sString = "At_5.2000_displacement" & @CRLF & _
"At_-6.4000_displacement" & @CRLF & _
"At_-0.4000_displacement" & @CRLF & _
"At_0.4000_displacement" & @CRLF & _
"At_2nd_-4.3000_displacement" & @CRLF & _
"At_2nd_2.2000_displacement"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")