package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`At_[-0-9.]*_displacement`)
var str = `At_5.2000_displacement
At_-6.4000_displacement
At_-0.4000_displacement
At_0.4000_displacement
At_2nd_-4.3000_displacement
At_2nd_2.2000_displacement`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}