re = /At_[-0-9.]*_displacement/
str = 'At_5.2000_displacement
At_-6.4000_displacement
At_-0.4000_displacement
At_0.4000_displacement
At_2nd_-4.3000_displacement
At_2nd_2.2000_displacement'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end