import re
regex = re.compile(r"At_[-0-9.]*_displacement")
test_str = ("At_5.2000_displacement\n"
"At_-6.4000_displacement\n"
"At_-0.4000_displacement\n"
"At_0.4000_displacement\n"
"At_2nd_-4.3000_displacement\n"
"At_2nd_2.2000_displacement")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")