using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"At_[-0-9.]*_displacement";
string input = @"At_5.2000_displacement
At_-6.4000_displacement
At_-0.4000_displacement
At_0.4000_displacement
At_2nd_-4.3000_displacement
At_2nd_2.2000_displacement";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}