import Foundation
let pattern = #"At_[-0-9.]*_displacement"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
At_5.2000_displacement
At_-6.4000_displacement
At_-0.4000_displacement
At_0.4000_displacement
At_2nd_-4.3000_displacement
At_2nd_2.2000_displacement
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)