import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "At_[-0-9.]*_displacement";
final String string = "At_5.2000_displacement\n"
+ "At_-6.4000_displacement\n"
+ "At_-0.4000_displacement\n"
+ "At_0.4000_displacement\n"
+ "At_2nd_-4.3000_displacement\n"
+ "At_2nd_2.2000_displacement";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}