# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\\/?(strong|b|i|em|br))(.?\\/)??>/<$1>/gmi;t' <<< "<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>"