import re
regex = re.compile(r"<(\/?(strong|b|i|em|br))(.?\/)??>", flags=re.MULTILINE | re.IGNORECASE)
test_str = "<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>"
subst = "<$1>"
result = regex.sub(subst, test_str)
if result:
print(result)