re = /<(\/?(strong|b|i|em|br))(.?\/)??>/mi
str = '<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>'
subst = '<$1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result