// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<(\/?(strong|b|i|em|br))(.?\/)??>").unwrap();
let string = "<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>";
let substitution = "<$1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}