import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\/?(strong|b|i|em|br))(.?\\/)??>";
final String string = "<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>";
final String subst = "<$1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}