package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<(\/?(strong|b|i|em|br))(.?\/)??>`)
var str = `<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>`
var substitution = "<$1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}