const regex = /<(\/?(strong|b|i|em|br))(.?\/)??>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\\/?(strong|b|i|em|br))(.?\\\/)??>', 'gmi')
const str = `<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>`;
const subst = `<$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);