use strict;
my $str = '<p>This is a <B>Bold</b> test to check <Strong>Strong</strong> <a href="www.google.com">Links</a> with <i>Italics</I> and <em>more italics</em><br> and other <div> various tags </div> that <br />should not be retained</p>';
my $regex = qr/<(\/?(strong|b|i|em|br))(.?\/)??>/mip;
my $subst = '<$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";