using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+";
string input = @"M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}