const regex = /M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('M\\D*[\\d\\.]+\\s*[a-zA-Z]*\\s*[\\d\\.]+', 'gm')
const str = `M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}