$re = '/M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+/m';
$str = 'M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1       3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);