import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "M\\D*[\\d\\.]+\\s*[a-zA-Z]*\\s*[\\d\\.]+";
final String string = "M between 1 and 12\n"
+ "M abcdeghi 12\n"
+ "Mdasklfasdlj123\n"
+ "M 1 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}