// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+").unwrap();
let string = "M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}