package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+`)
var str = `M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}