re = /M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+/m
str = 'M between 1 and 12
M abcdeghi 12
Mdasklfasdlj123
M 1 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end