using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)";
string substitution = @"";
string input = @"Log Started
Created Date: 01/01/01 Time: 01:01:01 Start
Added resources at module on 01/01/01 01:01
Module 2 excecute
Resource depleted at 01:01 n pieces
Open 01/01/01 01:01:01 Log to refer
Target end date of new resource 01/01/01 approved
Log Ended. Result OK";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}