# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)"
test_str = ("Log Started\n"
"Created Date: 01/01/01 Time: 01:01:01 Start\n"
"Added resources at module on 01/01/01 01:01\n"
"Module 2 excecute\n"
"Resource depleted at 01:01 n pieces\n"
"Open 01/01/01 01:01:01 Log to refer\n"
"Target end date of new resource 01/01/01 approved\n"
"Log Ended. Result OK")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.