// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)").unwrap();
let string = "Log Started
Created Date: 01/01/01 Time: 01:01:01 Start
Added resources at module on 01/01/01 01:01
Module 2 excecute
Resource depleted at 01:01 n pieces
Open 01/01/01 01:01:01 Log to refer
Target end date of new resource 01/01/01 approved
Log Ended. Result OK";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}