const regex = /(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}(\\d{2})?\\\/\\d{2}\\\/\\d{2}(\\d{2})?)|(\\d{2}:\\d{2}(:\\d{2})?)', 'g')
const str = `Log Started
Created Date: 01/01/01 Time: 01:01:01 Start
Added resources at module on 01/01/01 01:01
Module 2 excecute
Resource depleted at 01:01 n pieces
Open 01/01/01 01:01:01 Log to refer
Target end date of new resource 01/01/01 approved
Log Ended. Result OK`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);