import Foundation
let pattern = #"(\d{2}(\d{2})?\/\d{2}\/\d{2}(\d{2})?)|(\d{2}:\d{2}(:\d{2})?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Log Started
Created Date: 01/01/01 Time: 01:01:01 Start
Added resources at module on 01/01/01 01:01
Module 2 excecute
Resource depleted at 01:01 n pieces
Open 01/01/01 01:01:01 Log to refer
Target end date of new resource 01/01/01 approved
Log Ended. Result OK
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)