import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}(\\d{2})?\\/\\d{2}\\/\\d{2}(\\d{2})?)|(\\d{2}:\\d{2}(:\\d{2})?)";
final String string = "Log Started\n"
+ "Created Date: 01/01/01 Time: 01:01:01 Start\n"
+ "Added resources at module on 01/01/01 01:01\n"
+ "Module 2 excecute\n"
+ "Resource depleted at 01:01 n pieces\n"
+ "Open 01/01/01 01:01:01 Log to refer\n"
+ "Target end date of new resource 01/01/01 approved\n"
+ "Log Ended. Result OK";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}