# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/(?:[^\/\r\n]+\\/){2}.+/123/gm;t' <<< "/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
"