package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/(?:[^/\r\n]+\/){2}.+`)
var str = `/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
`
var substitution = "123"
fmt.Println(re.ReplaceAllString(str, substitution))
}