#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\/(?:[^/\r\n]+\/){2}.+"
Local $sString = "/home/user" & @CRLF & _
"/home/user/" & @CRLF & _
"/home/user/foo" & @CRLF & _
"/home/user/foo/" & @CRLF & _
"/home/user/foo/bar" & @CRLF & _
"/dog/.cat/frog" & @CRLF & _
""
Local $sSubst = "123"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)