using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?:[^/\r\n]+\/){2}.+";
string substitution = @"123";
string input = @"/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}