import Foundation
let pattern = #"^\/(?:[^/\r\n]+\/){2}.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"123"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)