re = /^\/(?:[^\/\r\n]+\/){2}.+/m
str = '/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
'
subst = '123'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result