// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/(?:[^/\r\n]+\/){2}.+").unwrap();
let string = "/home/user
/home/user/
/home/user/foo
/home/user/foo/
/home/user/foo/bar
/dog/.cat/frog
";
let substitution = "123";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}