import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(?:[^/\\r\\n]+\\/){2}.+";
final String string = "/home/user\n"
+ "/home/user/\n"
+ "/home/user/foo\n"
+ "/home/user/foo/\n"
+ "/home/user/foo/bar\n"
+ "/dog/.cat/frog\n";
final String subst = "123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}