#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d(?!\d{22})(102030)\d{10}"
Local $sString = "75277887243040354513001" & @CRLF & _
"55345377243014107206375" & @CRLF & _
"810203087654135168" & @CRLF & _
"1102030698798798477" & @CRLF & _
"71020307248040361799581"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")