using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d(?!\d{22})(102030)\d{10}";
string input = @"75277887243040354513001
55345377243014107206375
810203087654135168
1102030698798798477
71020307248040361799581";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}