import re
regex = re.compile(r"\d(?!\d{22})(102030)\d{10}")
test_str = ("75277887243040354513001\n"
"55345377243014107206375\n"
"810203087654135168\n"
"1102030698798798477\n"
"71020307248040361799581")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")