re = /\d(?!\d{22})(102030)\d{10}/
str = '75277887243040354513001
55345377243014107206375
810203087654135168
1102030698798798477
71020307248040361799581'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end