import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d(?!\\d{22})(102030)\\d{10}";
final String string = "75277887243040354513001\n"
+ "55345377243014107206375\n"
+ "810203087654135168\n"
+ "1102030698798798477\n"
+ "71020307248040361799581";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}