$re = '/\d(?!\d{22})(102030)\d{10}/';
$str = '75277887243040354513001
55345377243014107206375
810203087654135168
1102030698798798477
71020307248040361799581';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);