# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[.+?(?(?<= - ) - |\])/\1\n/gm;t' <<< "[category - subcategory] [some text - more text] [2018-12-31] text title here
[category - subcategory] [some text] [2018-12-31] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text"