const regex = /\[.+?(?(?<= - ) - |\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[.+?(?(?<= - ) - |\\])', 'gm')
const str = `[category - subcategory] [some text - more text] [2018-12-31] text title here
[category - subcategory] [some text] [2018-12-31] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);