import Foundation
let pattern = #"\[.+?(?(?<= - ) - |\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[category - subcategory] [some text - more text] [2018-12-31] text title here
[category - subcategory] [some text] [2018-12-31] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)