#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[.+?(?(?<= - ) - |\])"
Local $sString = "[category - subcategory] [some text - more text] [2018-12-31] text title here" & @CRLF & _
"" & @CRLF & _
"[category - subcategory] [some text] [2018-12-31] text title here more text" & @CRLF & _
"" & @CRLF & _
"[category] [some text - more text - even more] [2018-12-31] text title here more text"
Local $sSubst = "\1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)