import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.+?(?(?<= - ) - |\\])";
final String string = "[category - subcategory] [some text - more text] [2018-12-31] text title here\n\n"
+ "[category - subcategory] [some text] [2018-12-31] text title here more text\n\n"
+ "[category] [some text - more text - even more] [2018-12-31] text title here more text";
final String subst = "\\1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}