import re
regex = re.compile(r"\[.+?(?(?<= - ) - |\])", flags=re.MULTILINE)
test_str = ("[category - subcategory] [some text - more text] [2018-12-31] text title here\n\n"
"[category - subcategory] [some text] [2018-12-31] text title here more text\n\n"
"[category] [some text - more text - even more] [2018-12-31] text title here more text")
subst = "\\1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)