use strict;
my $str = '[category - subcategory] [some text - more text] [2018-12-31] text title here
[category - subcategory] [some text] [2018-12-31] text title here more text
[category] [some text - more text - even more] [2018-12-31] text title here more text';
my $regex = qr/\[.+?(?(?<= - ) - |\])/mp;
my $subst = '\\1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";