# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(s1|s2|s3|s4)|(sA|sB|sC|sD)|(s@|s#|s\$|s%)/${1:+s5}${2:+sE}${3:+s£}/gm;t' <<< "s1 sA s3 s@"